Linux

centos安装php7.2

明亮 · 12月27日 · 2018年

目前php最高稳定版本是7.2,wordpress中也建议采用该版本。

若直接采用centos中的yum安装:sudo yum -y install php,版本是5.4,远远不够,因此我们要手动更新rpm即可。

首先获取rpm:

rpm -Uvh https://dl.fedoraproject.org/pub/epel/epel-release-latest-7.noarch.rpm

rpm -Uvh https://mirror.webtatic.com/yum/el7/webtatic-release.rpm

然后可以利用 sudo yum list php*查看目前都有php的什么版本了,可以发现从4-7.2的版本都有,7.2版本名为72w,因此安装该版本即可:

yum -y install php72w

但安装完毕后,输入php -v发现并没有该命令,因为php72w只是安装了php最小的库,一些应用还未安装,因此安装一些拓展包即可:

yum -y install php72w-cli php72w-common php72w-devel php72w-mysql

对于wordpress应用,可能还需安装如下包:

yum -y install php72w-gd php72w-imap php72w-ldap php72w-odbc php72w-pear php72w-xml php72w-xmlrpc

然后输入php -v出现如下信息:

安装完毕。

但目前apache不知道我们php版本已更改,因此php网页用不了apache也就是httpd。比如在/var/www/html/目录下建立一个info.php文件,该目录是网页的根目录,也就是在浏览器中访问:IP/info.php即可出现info.php的内容。我们编辑info.php文件如下:

vim /etc/www/html/info.php

按i切换到vi的输入模式,然后输入以下内容:wq!保存并退出:

<?php
phpinfo();
?>

在浏览器输入IP/info.php,发现找不到该页面。因为说过apache不知道我们改了php版本,导致解析失败。

因此为了让apache支持php7.2,需要修改apache的配置文件:

首先,找到php的配置文件:php.ini,利用find命令:

find / -name php.ini

通常情况下位于/etc中,也就是/etc/php.ini。

修改该配置文件short_open_tag对应的值为on开启短标签模式。

short_open_tag = on

然后找到apache的配置文件:httpd.conf

find / -name httpd.conf

位置如下:

/etc/httpd/conf/httpd.conf

然后修改该文件,在该文件最后一行加上:

PHPIniDir /etc/php.ini

表示告诉apache,php的配置信息文件。

保存即可,然后重新在浏览器中输入IP/info.php

网页如下:

0 条回应